go to sections menu

Urgent issue with AI squared access technology from blog The Technology blog and podcast

This is for the technology blog and podcast Commentary, articles, and podcasts

header picture for Ingegno theme

You are here: accessibility newsand issues > Urgent issue with AI squared access technology

Go to Homepage, contents or to navigation menu



Urgent issue with AI squared access technology

Hello folks,

Thanks to Shaun, he tipped me off to this. The following is text sent from a word document sent to me after I enquired to AI’s window-eyes division. If you use any of these products, its important that you read this, and upgrade your product to the latest version.

Beginning of text from AI squared

January 16, 2017: Urgent Notification

Forthcoming Startup Failures in ZoomText 10.1 and other Ai Squared Software Products

Problem

The digital certificate used to certify newer ZoomText and Window-Eyes software products has been compromised. As a result, our certificate will be revoked on or around January 26th, which will result in startup failures for the following Ai Squared products.

Affected Ai Squared Software Products

When attempting to start the following Ai Squared software products, the product will fail to launch and display a Windows error message: “A referral was returned from the server”

  • * ZoomText Magnifier v10.1 Build numbers 10.10.8 through 10.11.6
  • * ZoomText Magnifier/Reader v10.1 Build numbers 10.10.8 through 10.11.6
  • * ZoomText Fusion v10.1 Build numbers 10.11.1 through 10.11.5
  • * ZoomText Keyboard v4 Build numbers 4.0.0 and 4.1.0
  • * Window-Eyes v9.5 Build numbers 9.5.1 and 9.5.3

When attempting to start the following Ai Squared software products, the product may launch even though the certificate has been revoked. Anti-virus utilities may detect the invalid certificate and block the software from running.

  • * ZoomText ImageReader v1.2 Build numbers 1.2.16106
  • * ZoomText Voices (language packs) v1.0 Build numbers 1.0.1.4693
  • * Vocalizer Expressive v1.3 (for Windows Eyes) Build numbers 1.3.0.13329

Note: Inspection of the certificate will show that the certificate is invalid. Inspection and validation of certificates is a process performed by some organizations.

Solution (software updates)

For each of the affected products, software updates incorporating a new digital signature will be released and available for download prior to January 26th. We will send updated information as it becomes available. You can check https://www.aisquared.com/certificatefix”>https://www.aisquared.com/certificatefix for updated information.
Software Product Update version

  • ZoomText Magnifier v10.1 10.11.7
  • ZoomText Magnifier/Reader v10.1 10.11.7
  • ZoomText Fusion v10.1 10.11.7
  • ZoomText Keyboard v4.1 4.1.1
  • Window-Eyes v9.5 9.5.4
  • ZoomText ImageReader 1.2 1.3.0
  • ZoomText Voices v1.0 1.0.2
  • Vocalizer Expressive v1.3 (for Windows Eyes) 1.3

Warning When Disabling Security Options

Various websites provide steps for disabling Windows security options with the expectation that unsigned software executables will start and run. Disabling these security options will not fix these problems for the ZoomText and Windows Eyes products and may compromise security and protection from malware. Ai Squared strongly recommends against disabling these security options.

Conclusion

We apologize for the inconvenience this issue has caused you, but assure you we are doing everything possible to rectify this matter as soon as possible. To minimize downtime, we encourage you to update your software as soon as possible.
If you have questions or require assistance resolving this problem, contact the Ai Squared support team at (727) 803-8600 option 2 or mailto:support@aisquared.com.

As some of you may have already noticed, we just released English Window-Eyes 9.5.4 this morning (January 18th). Other languages will soon follow. It is very important if you are using Window-Eyes 9.5.1 or 9.5.2 or 9.5.3 that you upgrade to 9.5.4 before the digital certificate described above is revoked.

There are 3 changes from version 9.5.3 to 9.5.4:

  1. Support has been added for the HumanWare BrailleNote Touch braille display.
  2. An issue where multiple hooking errors would occur in the latest testing builds (insider build) of Windows 10 has been fixed.
  3. An updated digital certificate has been used to sign all executables. (as per the description above)

Again, it is critical you upgrade your copy of Window-Eyes 9.5.1 or 9.5.2 or 9.5.3 to 9.5.4 immediately. Once the certificate is revoke these copies of Window-Eyes will no longer launch leaving you without speech and/or braille.

Regards,
Doug

Doug Geoffray
VFO(tm) | Accessibility Software Manager, Enterprise Compliance
11800 31st Court North, St. Petersburg, FL 33716 mailto:dgeoffray@vfogroup.com http://www.vfogroup.com/

I am going to get in touch to understand what happened here. Just be aware of whats up, and update so you continue to have access to your information and can continue to work.

Be Sociable, Share!

Informazioni sull'articolo

Urgent issue with AI squared access technology was released on January 18, 2017 at 5:32 pm by tech in accessibility newsand issues.
Last modified: January 21, 2017.


Comments Off on Urgent issue with AI squared access technology

No comments yet.

Sorry, the comment form is closed at this time.

go to sections menu


navigation menu

go to sections menu